RudderStack has cleared all backlog across all customers. We do not see any lingering impact to customers. If you have questions contact your account team
Posted Oct 20, 2025 - 21:50 UTC
Monitoring
Data processing and event delivery has returned for all production customer workspaces although it might be delayed for some end destinations if those themselves are impacted by the AWS incident
Posted Oct 20, 2025 - 17:06 UTC
Update
Data processing and event delivery has returned for all production customer workspaces although it might be delayed for some end destinations if those themselves are impacted by the AWS incident
Posted Oct 20, 2025 - 17:04 UTC
Update
Data processing and event delivery has returned for most customers, a small subset of customers are still seeing impact due to AWS limiting resources. Our team is working to inform this small set of customers while working to restore the service. Data ingestion remains for these customers, processing and delivery remain impacted.
Posted Oct 20, 2025 - 14:17 UTC
Update
Customer-facing monitoring dashboards are also affected and may be incorrect, but this is a display issue only—data continues to be ingested normally and no data loss has occurred.
Posted Oct 20, 2025 - 12:39 UTC
Identified
Due to an ongoing AWS incident, a small portion of US customers are experiencing significant delivery latencies of more than an hour. However, event ingestion remains unaffected and no data loss has occurred. We are actively looking at ways to mitigate the issue. https://health.aws.amazon.com/health/status
Posted Oct 20, 2025 - 11:16 UTC
This incident affected: Data Processing Pipeline (Data Processing Pipeline (US)) and Web Application.