Instability Issue on RudderStack Control Plane on US, EU and IN region

Incident Report for Rudderstack

Resolved

This incident has been resolved.
Posted Jun 17, 2026 - 13:14 UTC

Monitoring

We have identified the issue and we are currently monitoring the system state.
Posted Jun 17, 2026 - 13:04 UTC

Update

The issue is increasing event delivery latency across customers, event ingestion has not been affected.
Posted Jun 17, 2026 - 12:52 UTC

Investigating

We are currently investigating the issue, data ingestion has NOT been affected.
Posted Jun 17, 2026 - 12:45 UTC
This incident affected: Data Processing Pipeline (Data Processing Pipeline (US), Data Processing Pipeline (EU)) and Control Plane / Public API.