Cloudflare and GCP outage causing delayed deliveries to affected cloud destinations

Incident Report for Rudderstack

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 22:27 UTC

Monitoring

Cloudflare and GCP have reported recovery and we are actively monitoring to ensure all events are retried and delivered to affected destinations. No data loss has been observed
Posted Jun 12, 2025 - 20:27 UTC
This incident affected: Data Processing Pipeline (Data Processing Pipeline (US), Data Processing Pipeline (EU)).