Partial delivery failures to TikTok destinations

Incident Report for Rudderstack

Resolved

The incident has been resolved. Changes made to determine how event_source is set to TikTok events broke the deliveries for its server SDK sources.

Change has been reverted and failures have been replayed for all customers with configured backup
Posted Aug 21, 2025 - 15:30 UTC

Identified

The issue has been identified and rollback is in progress
Posted Aug 21, 2025 - 15:15 UTC

Investigating

We are currently investigating the issue around failures for TikTok destinations
Posted Aug 21, 2025 - 07:00 UTC
This incident affected: Data Processing Pipeline (Data Processing Pipeline (US), Data Processing Pipeline (EU)).