Processing delays for workspaces on the free tier in RudderStack cloud

Incident Report for Rudderstack

Resolved

This incident has been resolved.
Posted Jul 21, 2026 - 17:31 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 21, 2026 - 17:28 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 21, 2026 - 17:28 UTC

Investigating

We are currently investigating a issue causing processing delays for free tier customers on RudderStack cloud
Posted Jul 21, 2026 - 15:32 UTC
This incident affected: Data Processing Pipeline (Data Processing Pipeline (US)).