Issues with python transformations in US.

Incident Report for Rudderstack

Resolved

RudderStack has cleared all backlog across all the python transformations. We do not see any lingering impact to customers. If you have questions contact your account team
Posted Oct 20, 2025 - 21:51 UTC

Monitoring

We are seeing successful increased launches of new EC2 instances and thus able to resource python transformations. We will be monitoring till all the backlog is cleared
Posted Oct 20, 2025 - 19:06 UTC

Identified

RudderStack is actively working to resolve the issues caused by the ongoing AWS incident.

Currently, customers in US using Python Transformations are impacted, and we are focused on restoring this feature as soon as possible. Our efforts are currently constrained by limited AWS resource availability, but we are exploring multiple options to restore full functionality.

We will share another update as soon as we have more information.
Posted Oct 20, 2025 - 15:32 UTC
This incident affected: Data Processing Pipeline (Data Processing Pipeline (US)).