Delivery delays in US region due to incident with our cloud service provider

Incident Report for Rudderstack

Resolved

This incident has been resolved.
Posted Jul 04, 2026 - 20:48 UTC

Monitoring

We are observing an improvement on successufully API calls to our cloud provider, event delivery times are recovering back to realtime.
Posted Jul 04, 2026 - 20:42 UTC

Identified

We've identified event delivery delays across customers in the US region. The root cause is due to an outage from our cloud provider. Event ingestion has not been affected.
Posted Jul 04, 2026 - 20:23 UTC

Investigating

We are currently investigating this issue.
Posted Jul 04, 2026 - 20:13 UTC
This incident affected: Data Processing Pipeline (Data Processing Pipeline (US), Data Processing Pipeline (EU), Data Processing Pipeline (IN)) and Warehouses.