Control Plane & Activation API Disruption

Incident Report for Rudderstack

Resolved

This incident has been resolved and all services are back to normal
Posted Dec 19, 2025 - 19:14 UTC

Monitoring

We are seeing recovery of the services. We are continuing to monitor the system to ensure stability and confirm full restoration
Posted Dec 19, 2025 - 18:53 UTC

Identified

We have identified the cause of the outage and rolling out a fix
Posted Dec 19, 2025 - 18:53 UTC

Update

We are investigating an issue causing an outage for a internal service, which is impacting several dependent components including the Control Plane and Activation API. Customers may experience errors accessing RudderStack web app or any other componets depending on it.

Note: No impact on event ingestion on the data planes
Posted Dec 19, 2025 - 18:51 UTC

Investigating

We are currently investigating this issue.
Posted Dec 19, 2025 - 18:40 UTC
This incident affected: Control Plane / Public API.