Mailchimp integration delivery issues for free, starter and growth customers in US

Incident Report for Rudderstack

Update

We resolved the issue for free tier customers. We are waiting on Mailchimp to establish an active communication channel to unblock our IPs for complete resolution.
Posted Dec 24, 2025 - 14:09 UTC

Update

We identified that RudderStack IPs are being blocked by Mailchimp’s Akamai proxy. We are working to establish an active communication channel with Mailchimp’s team to resolve this issue.
Posted Dec 15, 2025 - 17:00 UTC

Monitoring

All events routed to the Mailchimp cloud-mode destination for starter and growth customers in US region are failing consistently.
Posted Dec 10, 2025 - 00:00 UTC
This incident affects: Integrations.