We're investigating reports of an issue with Google Ads API's.

Incident Report for Rudderstack

Resolved

Deliveries to Google Ads Offline Conversions were impacted due to issues (unavailable, high latency and unexpected behavior) with Google Ads API as reported by Google (https://ads.google.com/status/publisher/incidents/xF9wKox7evao5WupR7mu). We’ve identified the affected customers and have completed a replay for all impacted destinations.
Posted Jul 03, 2025 - 03:30 UTC

Investigating

We are currently investigating this issue.
Posted Jul 02, 2025 - 16:30 UTC
This incident affected: Data Processing Pipeline (Data Processing Pipeline (US)).