Delay in data processing pipeline in US region

Incident Report for Rudderstack

Resolved

This incident has been resolved.
Posted May 08, 2026 - 02:57 UTC

Monitoring

Event processing has been resumed for Free, Starter and Growth customers, we are monitoring the pipeline's health.
Posted May 08, 2026 - 02:32 UTC

Update

Enterprise customers are not affected by this issue. The team is working on the issue for Free, Starter and Growth customers.
Posted May 08, 2026 - 02:12 UTC

Update

We are continuing to work on a fix for this issue.
Posted May 08, 2026 - 01:57 UTC

Identified

We are actively working on a solution to the issue.
Posted May 08, 2026 - 01:51 UTC

Update

We are moving some workloads away from the problematic availability zone in AWS.
Posted May 08, 2026 - 01:31 UTC

Update

We are still investigating the issue.
Posted May 08, 2026 - 01:04 UTC

Update

We are investigating instance impairments in a single Availability Zone (use1-az4) in the US-EAST-1 Region.
Posted May 08, 2026 - 00:43 UTC

Investigating

We are currently investigating an issue on our data processing pipeline due to an EC2 instance availability issue in the US region.
Posted May 08, 2026 - 00:33 UTC
This incident affected: Data Processing Pipeline (Data Processing Pipeline (US)).