Increased latency in US data processing pipeline

Incident Report for Rudderstack

Resolved

This incident has been resolved.
Posted Sep 21, 2026 - 23:58 UTC

Monitoring

There are fewer errors when calling the cloud provider's API. We will actively monitor for a few minutes.
Posted Sep 21, 2026 - 23:47 UTC

Investigating

We are currently investigating an issue in our data processing pipeline due to an EC2 instance availability issue in the US region. Data ingestion is NOT affected.
Posted Sep 21, 2026 - 23:23 UTC
This incident affected: Data Processing Pipeline (Data Processing Pipeline (US)).